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Problem Note 55344: When used in a Windows operating environment, the Deployment Backup and Recovery tool might fail to archive the backup to the central vault

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Problem

When you use the SAS® Deployment Backup and Recovery tool, it might fail to archive the backup to the central vault. The problem occurs when all of the following are true:

  • Hot Fix R75002 for middle-tier SAS® 9.4_M2 is installed.
  • You have configured your SAS 9.4 TS1M2 software on one or more tiers for the Windows operating environment.
  • A central vault (also known as a shared vault) is configured for the Deployment Backup and Recovery tool.
  • The backup is running for the first time after your SAS 9.4 TS1M2 software was deployed.

When the problem described here occurs, the Deployment Backup and Recovery tool reports a message that the archive operation failed because the shared vault is not accessible. Here is an example:

    statusCode:     321
    name:           ARCHIVE_SHARED_VAULT_NOT_ACCESSIBLE
    category:       GENERAL
    classification: ERROR
    message:        The archive operation failed because shared vault is not accessible.

Cause

The problem occurs when the backupserver.host.alias property hostname value is appended with the characters \r, as in this example: backupserver.host.alias=hostname\r

Workaround

To work around the problem, remove the \r characters as outlined in the following steps.

  1. Navigate to SAS-configuration-directory\Lev1\Backup.
  2. Locate and then open the file BackupServer.ini in a text editor, and remove the \r characters from the end of the hostname value for the property:
  3. backupserver.host.alias
  4. Save the file.
  5. Repeat steps 1 and 2 on each Windows host machine on which the SAS Deployment Backup and Recovery tool is configured.

Fixes

For SAS 9.4 TS1M2: Click the Hot Fix tab in this note to access the hot fix for this issue.

For SAS 9.4 TS1M3: The problem no longer exists and the hot fix is not needed.



Operating System and Release Information

Product FamilyProductSystemProduct ReleaseSAS Release
ReportedFixed*ReportedFixed*
SAS SystemSAS Deployment Backup and Recovery ToolMicrosoft Windows 8 Enterprise 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft® Windows® for x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Ultimate 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Ultimate x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Professional x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Professional 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Home Premium x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Home Premium 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Windows 7 Enterprise 32 bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 Std9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 R2 Std9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 R2 Datacenter9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2012 Datacenter9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2008 for x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 2008 R29.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows Server 20089.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Pro 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Pro9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8.1 Enterprise 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Pro x649.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Pro 32-bit9.4_M29.4_M39.4 TS1M29.4 TS1M3
Microsoft Windows 8 Enterprise x649.4_M29.4_M39.4 TS1M29.4 TS1M3
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.